Talk:Take 2 Full Update

From AwkwardTV
Jump to: navigation, search



Rather than installing all the various WMV / Flip4Mac bits, etc, why not just install Perian?

Perian is installed as part of the process. The other bits were thrown in based on forum posts. --kupan787 19:31, 18 February 2008 (CET)
Sooo, should we remove these comments from the article? --Maury Markowitz 21:24, 27 February 2008 (CET)
Sooo, does Perian enable WMV without Flip4Mac? --Underburn 09:59, 29 February 2008 (CET)
USB Hack

Would this still work?

- Not sure if that exact script will work, but the steps I outline to get USB working do indeed work just fine.
-kupan787 15:47, 19 February 2008 (CET)

problem is "Patch the kernal" is a bit beyond the average or even semi-literate user. I wrote the beginners guide and I wouldn't get far on what's on this page. Any chance of more detailed instructions? Getting the right kernal? How to patch (i.e. what script to run?). Kudos on the rest of the page though. Very nice.

-I plan on updating things with more detailed information on sections, and possible scripting aspects to simplify the process. My original goal was to make an uber-patchstick that just did it all, but initial tries failed. I hope to have more detailed instructions tonight.
kupan787 00:41, 20 February 2008 (CET)

Great - will keep an eye out. I have a Tiger intel mac mini in my hands again, so I can do some testing and sorting tonight, too. I think we're both aiming for the same thing: easy steps to patched 2.0 ATV.

Above script will kill ATV meaning factory restore. See new process is much better!

--Simplicity 15:13, 20 February 2008 (CET)

USB is working for me, but is there a way to enable external dvd-support (usb). With version 1.1 this worked? --Sollie 14:26, 23 February 2008 (CET)

As I have a PPC and can't patch Intel files, I managed to get USB working for the ATV1 & 1.1 by using the NitoTV download section. Any suggestions on how to patch the files for ATV2, as I believe NitoTV doesn't have this function working yet. --Paintstripper 27 February 2008

I followed the USB Instructions here, got all the required files (.kexts etc) and ran all the commands (sudo mv etc etc) but my USB Drives arent mounting still! When i plug in the drive nothing happens... And i did do the "sudo defaults write /Library/Preferences/SystemConfiguration/autodiskmount AutomountDisksWithoutUserLogin -bool true " command...Any ideas?

--Fireman 27 February 2008

I got USB working by manually executing the commands in the rc.local file at the Bash prompt. For some reason my rc.local file isn't automatically executing. External drives mount after I manually execute. This also fixed the problem I was having in NitoTV freezing when the "Files" command is selected.

--vhuang 28 February 2008

Running the do_usb_patch script fails on the line: ./prelink_tool -d mach_kernel.prelink mach_kernel_patched.bin Bus error

Running on an Intel Mac Mini Core Solo. I just noticed the files to copy from 1.0 OSBoot (or Tiger) to enable USB has shrunk dramatically. What was the reason? Thanks.

--Bloo 08:54, 9 March 2008 (CET)

Missing Files

Several users reporting missing files when enabling AFP:- AppleFileServer

Can these be copied from Tiger? Do they need permissions changing if so?

--Simplicity 21:52, 20 February 2008 (CET)

I just updated the page. and are not required, and not on the image. Not sure how I got them on my list. As far as AppleFileServer, that is on the image in /usr/sbin (I have triple verified this). I sent you a message, so hopefully we can track down the issue.
-kupan787 00:09, 21 February 2008 (CET)

Use patchstick to get ssh installed

Can I use exactly the same patchstick I have created for aTV v1.0? Or do I have to modify it addind the missing files?

I would like to: do factory restore --> update to aTV 2.0 using apple procedure --> restart aTV with patchstick v1.0 as described here: --> have ssh installed and enabled on aTV2.0

Is "Take_2_Full_Update" article describing this? thanks --Yanke 16:38, 19 February 2008 (CET)

You will need to add some files to your patchstick to get ssh running on the AppleTV with Take2. I am planning on updating the guide with more details on what and how to modify your patchstick with tonight when I get off work)

-kupan787 17:23, 19 February 2008 (CET)

I used the ssh, etc, apps from the 10.4.9 combo updater, as described here.

-marshylucas 22:32, 20 February 2008 (ET)

I made a patchstick, but it doesn't seem to be working even with the changes for Take 2. I get an error message while booting about the RTL8139 driver (seems to be about the network adaptor) --- EDIT --- I'm using a Sandisk 1GB (dunno if it's related or not) and to make it work I unplugged it when the RTL8139 error appeared and then I plugged it back in and the rest of the process went on... weird, but it worked! SSH activated, I'm in!


The instructions on the article page worked for me. I typed these up after the fact, but it was using all the files I had obtained in my update folder. Please post if you have any issues.
(kupan787 08:29, 18 February 2008 (CET))

HD Rental Info

Rented movies are stored in /mnt/Media/Rental Files/Movies
They can be transfered to a computer, and loaded into iTunes. Itunes sees it as a rental (and has information about it). When you try and play it, it says the movie is authorized for another device already and can not be played.

[Click here for a Screen Shot]

Most important question ever...

  •  :-)

is nitoTV working?

Follow the status here:

ATVFiles install steps

Please recommend installing ATVFiles with the installer (the .run file) instead of copying the frappliance over. I've updated this page to do so. Thanks!

--ericIII 17:01, 18 February 2008 (CET)


This file is not in the 10.4.9 combo updater I got from the apple site. Where can it be found?

This file really isn't needed, it was part of the Nito Package to get DVD playback working. If all you care able is USB support, you can omit that. - kupan787 04:15, 19 February 2008 (CET)

SSH Problem

Ok, so i got SSH on the @tv, and it starts, but when i connect all i get is the following error....

$> ssh frontrow@appletv.local
ssh_exchange_identification: Connection closed by remote host

I have tried the -1 switch to force version one and removed my ~/.ssh/known_hosts with no change. --Dr Omega 02:19, 20 February 2008 (CET)

-- Ah, I found the problem, I didnt have /usr/libexecs/sshd-keygen-wrapper nor the Kerberos framework. Installed those and now it works perfectly.

-- I have both /usr/libexecs/sshd-keygen-wrapper and Kerberos but ssh is not working for me. I'm getting:

 ssh -1 frontrow@apple
 Protocol major versions differ: 1 vs. 2


 ssh -2 frontrow@apple
 Unable to negotiate a key exchange method

Where do you put the Kerberos from MacOSX? And do you edit sshd-keygen-wrapper?

The installer.d/ssh script doesn't do the sed properly. If it did, it would update the sshd-keygen-wrapper correctly to enable Kerberos, and allow -2 for ssh. sed needs to be invoked from its full path (/sbin/sed? /usr/bin/sed? I haven't tested yet), and the -i"" should be changed to -i "" to work correctly.

Can these download-able, non (c) files (like the Patchstick*.zip files, etc) be uploaded to a versioning repository like Google Code or sourceforge somewhere? They're randomly scattered and contain bugs in some versions that don't exist in others.

--Bloo 18:51, 10 March 2008 (CET)

Updated AFP and USB sections

I have updated the AFP and USB sections. AFP now contains a script you run, and it should properly setup AFP. The USB section has been updated with more details as well, so as to be a bit more clear.

-marshylucas 7:35, 21 February 2008 (ET)

It's not working for me, perhaps the recovery partition is 1.1 instead of 1.0? I get a lot of "No such file or directory"
--Magu 10:54, 22 February 2008 (CET)
Try editing the file in a Mac text editor and adding an extra Enter after the touch /.readwrite line. Save the file using LF (line feed in TextMate) and it should work. Took me a while to figure out that the encoding of the file is wrong (Windows, maybe?).
--Magu 11:13, 22 February 2008 (CET)
Script ran without problems or errors, but no AFP.
Script was created on a Windows box, so sorry if the formatting is a little messed up (I was at work). No problems, but no AFP...hmm. Do a:
more /etc/hostconfig
and let me know if the first line says YES or NO. Also note that once I enabled AFP, I had to manually connect to the AppleTV (Go menu in the FInder, type in the IP address). The device didn't automatically show up in the side bar.
-kupan787 16:43, 22 February 2008 (CET)
Interesting... Even though I manually changed the hostconfig file to YES, it reverted back to NO. Apparently the SED line is not working for me, even though it shows -YES- when I run it, after a 'more /etc/hostconfig' shows -NO- again. Did the change manually by copying the file back and forth and using nano on my own Mac and it seems to work fine, even showing up on the sidebar. Now it's just a matter of waiting for Sapphire.
I took the manual path and it worked fine, but I had to use the that I kept from my previous hack, because it wasn't on the recovery partition.
-marshylucas 1:06, 22 February 2008 (ET)

The instructions for AFP didn't quite work for me. I have a 1.0 recovery partition and the script ran successfully. After running it though, I got an error from mount_afp indicating that it needed to be run as root. I had to go through and "chown -R root:wheel" to all the items touched by the script. Then I got an error about loading two different kext files. I had to run the turbo_kext_enabler.bin. The way the instructions are written, it looks like the kext enabler is only used for the usb hack. It wasn't clear to me that I'd need it for mount_afp to run. Note that I could mount the appletv's shares on my imac before running turbo_kext_enabler, so the file sharing portions were working, just not the mounting. I still can't get an rc.local to work which automates the process of mounting the share, but I can now log in and mount the share manually, so I'm happy enough. --Globalreset 16:24, 25 February 2008 (CET)

Note that the instructions I posted are for getting the AppleTV to have AFP running, so you can mount it on a mac. The instructions are not for mounting AFP shares on the AppleTV. If you managed to get it working, all the better, perhaps I can add that (or you can add it) to another section on the guide. Additionaly, my rc.local appears to be running, as my turbo_kext_loder runs everyboot, and my USB drive mounts every boot. --kupan787 20:13, 25 February 2008 (CET)

Used both the script and the manual method and getting a number of messages that look like

   cp: /Volumes/OSBoot 1/System/Library/Filesystems/AppleShare: No such file or directory

This one is for AppleShare, but also getting them for, atlookup,, appletalk, automount, blued, portmap, slp_reg, slpd, xinetd, and mount_afp. I typed more /etc/hostconfig and it gave me the right answers. Any suggestions?--Cgates30 09:04, 26 February 2008 (CET)

  • Is it possible that the recovery partition is from 1.1? Regardless, you can get the files you need from the 10.4 combo update listed elsewhere. --Dr Omega 15:08, 26 February 2008 (CET)

I just pulled most of those files from the 10.4.9 update image. There were a few files still missing AppleShare, appletalk, portmap, xinetd and mount_afp. Should those be on the image, or maybe on the full install disc? (I have 10.4.5 install discs.) thanks--Cgates30 17:33, 26 February 2008 (CET)

  • Ah, I see. yah, shouldl be on the install disk, in the Essensials or BSD package of the first disk. --Dr Omega 17:45, 26 February 2008 (CET)

Finding them. Thanks! --Cgates30 17:50, 26 February 2008 (CET)

AFP still not working. I figure I must have the 1.1 partition since I didn't have AppleFileServer and other files listed in my first message above. I pulled those files from my Tiger install disk, copied them into a separate directory in the frontrow directory on the ATV, and then gave the following commands to copy them from that directory to where they belong according to the script. Here are the commands I typed:

    sudo cp -pr /Volumes/OSBoot/Users/frontrow/test/ /System/Library/CoreServices/
    sudo cp -pr /Volumes/OSBoot/Users/frontrow/test/AppleShare /System/Library/Filesystems/
    sudo cp -pr /Volumes/OSBoot/Users/frontrow/test/atlookup /usr/bin/
    sudo cp -pr /Volumes/OSBoot/Users/frontrow/test/ /usr/lib/
    sudo cp -pr /Volumes/OSBoot/Users/frontrow/test/appletalk /usr/sbin/
    sudo cp -pr /Volumes/OSBoot/Users/frontrow/test/automount /usr/sbin/
    sudo cp -pr /Volumes/OSBoot/Users/frontrow/test/blued /usr/sbin/  
    sudo cp -pr /Volumes/OSBoot/Users/frontrow/test/portmap /usr/sbin/
    sudo cp -pr /Volumes/OSBoot/Users/frontrow/test/slp_reg /usr/sbin/
    sudo cp -pr /Volumes/OSBoot/Users/frontrow/test/slpd /usr/sbin/   
    sudo cp -pr /Volumes/OSBoot/Users/frontrow/test/xinetd /usr/sbin/
    sudo cp -pr /Volumes/OSBoot/Users/frontrow/test/mount_afp /sbin/ 
    sudo reboot

After the ATV rebooted, I still can't connect to it through the finder->Go->Connect to Server using the IP address. Am I doing this the wrong way? Also, the script used the path /Volumes/OSBoot\ 1/.... where I used /Volumes/OSBoot... to my test directory. Any significance to that? --Cgates30 07:39, 27 February 2008 (CET)

There is no /Volumes/OSBoot 1/ directory, only /Volumes/OSBoot/ does the "1" belong in the script?

USB problems?

I have followed these instructions and while AFP was easily enabled, USB doesn't seem to work. Whenever I attach a USB storage device, I get these messages in my dmesg:

USB Drive: family specific matching fails

While I get this mesage, no drive appears in 'diskutil list' nor is any drive auto-mounted.

Full dmesg output (from boot):

sh-2.05b# dmesg
hi mem tramps at 0xffe00000
PAE enabled
standard timeslicing quantum is 10000 us
vm_page_bootstrap: 59381 free pages
mig_table_max_displ = 71
Enabling XMM register save/restore and SSE/SSE2 opcodes
60 prelinked modules
ACPI CA 20060421
AppleACPICPU: ProcessorApicId=0 LocalApicId=0 Enabled
AppleACPICPU: ProcessorApicId=1 LocalApicId=0 Disabled
Copyright (c) 1982, 1986, 1989, 1991, 1993
The Regents of the University of California. All rights reserved.
using 1310 buffer headers and 1310 cluster IO buffer headers
IOAPIC: Version 0x20 Vectors 64:87
ACPI: System State [S0 S4] (S0)
NVDANV40HAL loaded and registered.
display: family specific matching fails
EHCI Root Hub Simulation: family specific matching fails
Security auditing service present
BSM auditing present
rooting via boot-uuid from /chosen: 00003C01-3B38-0000-5474-000040310000
Waiting on <dict ID="0"><key>IOProviderClass</key><string ID="1">IOResources</string><key>IOResourceMatch</key><string ID="2">boot-uuid-media</string></dict>
USB caused wake event (EHCI) 
wl0: Broadcom BCM4328 802.11 Wireless Controller Root Hub Simulation: family specific matching fails
USB Drive: family specific matching fails
Got boot device =
IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/PATA@1F,1/AppleIntelPIIXATARoot/PRID@0/AppleIntelPIIXPATA/ATADeviceNub@0/IOATABlockStorageDriver/IOATABlockStorageDevice/IOBlockStorageDriver/FUJITSU MHW2040AT Media/IOGUIDPartitionScheme/OSBoot@3

BSD root: disk0s3, major 14, minor 3
com_apple_IRRecovery::probe(IR Receiver)
com_apple_IRRecovery::start(IR Receiver) <1>
com_apple_IRRecovery(0x1bb2780)::start - This is the HID Receiver device, disable recovery
com_apple_IRRecovery(0x1bb2780)::start Exiting
com_apple_IRRecovery(0x1bb2780)::start - defining AppleIRRecoveryDisabled to disable IR Recovery from occurring (again)
com_apple_IRRecovery(0x1bb2780)::start - Intentionally fails, because work is done in start. This frees up resources.
com_apple_IRRecovery::start(IR Receiver) <1> failed
IOGMD(0x1bd7e00): wB = o0, l1
IOGMD(0x1bd7e00): wB = o0, l3
jnl: close: flushing the buffer cache (start 0x6dba00 end 0x6ddc00) 
RTL8139::registerEEPROM: 8129 10ec 8139 10ec   8139 4020 e510 1700
RTL8139::registerEEPROM: f9f2 d635 8d10 f7c2   8801 03b9 60f4 071a
RTL8139::registerEEPROM: dfa3 9836 dfa3 9836   03b9 60f4 1a1a 1a1a
RTL8139::registerEEPROM: 0000 2d09 0000 0000   0000 0000 0000 2000
RTL8139::registerEEPROM: 0000 0000 0000 0000   0000 0000 0000 0000
RTL8139::registerEEPROM: 0000 0000 0000 0000   0000 0000 0000 0000
RTL8139::registerEEPROM: 0000 0000 0000 0000   0000 0000 0000 0000
RTL8139::registerEEPROM: 0000 0000 0000 0000   0000 0000 0000 0000
Jettisoning kernel linker.
Resetting IOCatalogue.
com_apple_driver_RTL8139: Ethernet address 00:17:f2:f9:35:d6
AirPort_Brcm43xx: Ethernet address 00:19:e3:dc:ce:2a
SetCryptoKey T: len 16, idx 0
SetCryptoKey R: len 16, idx 1

Anyone got any ideas?? Crowland 02:28, 23 February 2008 (CET)

I found the problem - turbo's kext enabler wasn't +x - so it didn't work. Once I chmod it u+x it worked :-)
06:06, 24 February 2008 (CET)

I also have that warning, but its working. Did you enable automount? --Sollie 14:30, 23 February 2008 (CET)

I have the same error message:

USB Mass Storage Device: family specific matching fails

... but USB HFS+ and FAT drives work and automount (tried with an external hard drive and a flash drive.

However, a USB DVD-ROM drive fails to automount. Don't know why, since I can mount it by typing:

sudo mount -t udf -r /dev/disk1 ~/Movies/DVD

Any ideas? Is there some config necessary for automount so that it knows to mount the UDF filetype automatically?

I did it. Automounting is working. I copied all the filesystem files from my osx86 (/System/Library/Filesystems/) to my apple tv. --Sollie 19:03, 23 February 2008 (CET)

When i boot my apple TV with the DVD-drive hooked up, the system hangs. Is this normal? I cant boot with an dvd drive attached?

Thanks Sollie,

I was missing some filesystems. Copied the UDF filesystem over and it automounted no problem! --Mdonahuerib 00:20, 24 February 2008 (CET)

I've got some an error message (bus error) while trying to patch mach_kernel.prelink . What is happening (everythings else worked fine)? --Ludo

  • You have to do the kernel patch from an osx box, not on the apple. --Dr Omega 15:10, 26 February 2008 (CET)

I've the got the same error when trying to patch the kernel. I am using a macbook pro booted to 10.4.8 can't decompress the file for some reason ?? --FRoSTY 19:02, 26 February 2008 (CET)

  • hm, not sure, I did mine on 10.5 without a problem.

- I've just booted into to 10.5 and it worked, strange that it didn't work for me under 10.4.8... ? --FRoSTY 19:31, 26 February 2008 (CET)

- Yup, same problem here on MacBook Pro with 10.4.11. reports "line 21: 522 Bus error" and dies. --Boybert 07:15, 27 February 2008 (CET)

    -Was able to get this done on a 10.5 machine.  So, should it be specified that Leopard is required for this step, or is that not the issue? --Boybert 04:10, 28 February 2008 (CET)

- Can not get USB to work --Ptv 16:41, 27 February 2008 (UTC)

For some reason I think the kext files do not get loaded proparly. To see what is happening I redirected the output from what is going on in rc.local to a file.

Here is what I get :

This program is copyright 2007 Turbo (Mike Byrne) and MAY NOT be distributed. All rights reserved. Contact for more information

Patch OK /mach: No such file or directory kextload: extension /System/Library/Extensions/IOUSBMassStorageClass.kext appears to be valid kextload: loading extension /System/Library/Extensions/IOUSBMassStorageClass.kext Can't open /mach for reading - No such file or directory kextload: can't map module files kextload: can't check load addresses of modules kextload: a link/load error occured for kernel extension /System/Library/Extensions/IOUSBMassStorageClass.kext kextload: sending 1 personality to the kernel

Not to make this endless, I have only copied the ouput of the first extension being "loaded", but all others are the same. Anyone who can help ?

Attaching USB HDD Causes Crash

Everything seemed cool after I followed these instructions. After the final restart, I plug in my USB HDD and the Apple TV immediately reboots on its own. Then it just goes into this infinite reboot cycle. As soon as I unplug the drive, the ATV reboots successfully and everything's fine. Anyone else have this experience? --Boybert 04:10, 28 February 2008 (CET)

Did you do this on Leopard or a late version of Tiger? Only up to something like 10.4.10 works.

--Simplicity 19:43, 7 March 2008 (CET)

I was using Tiger 10.4.11. However, I patched the kernel on a Leopard machine, because I couldn't get any of my Tiger machines to do the job. Could that be the issue? --Boybert 22:26, 7 March 2008 (CET)

ATV 2.0.1 update

is there any progress on patching the 2.0.1 update? --LeMarsu 15:44, 31 March 2008 (CEST)

Alternate 3 to 8

Alternate 3 to 8 a) Copy MacOS X 10.4.9 Combo Updater to ~/Documents folder on AppleTV

- I do not understand why in this step you need to copy over the "MacOS X 10.4.9 Combo Updater" to your AppleTV? When I installed nitoTV it did not prompt me to have this image mounted.

Huh? "Alternate" method?

Q: Right in the middle of the installation text is a section called "Alternate 3 to 8". If I'm reading it correctly, if I simply place a few files on the ATV and install nito, everything else is done for me. Is this correct? If so, is there any reason that I shouldn't use this method? I was going to install nito anyway... Maury Markowitz 22:43, 11 May 2008 (CEST)

A: Using NitoTV's smart installer is indeed the best and easiest way to add USB and Network features after patchstick. Once you install NitoTV you still need to use its install features:

Go to the Software Install feature in nito:

1. Install Perian (say NO when asked to use Perian h.264 instead of Quicktime's )

2. Install mPlayer codecs

3. Copy the OSX10.4.9INTEL.dmg and the 1.0 recovery.dmg to frontrow/Documents on the AppleTV (using a SSH copy command in the Terminal or using FUGU)

4. Turbo's Kextloader

5. Run the Nito Smart Installer

You can than skip to step 11 (not 8) --Drag0n 09:15, 12 May 2008 (CEST)