From AwkwardTV
Jump to: navigation, search

If this runs without signature verification, would it be possible to download the update .dmg and install ssh on the update dmg file. From then you can just update to the next version and don't need to patchstick it?

osupdate download doesn't work is not downloading as a binary but as text in a browser window. MIME type issue perhaps?

Error in auto-script for 2.1

In line 6 and 7 there is a small mistake: it reads
mkdir /User/frontrow/OStemp
rm /User/frontrow/OStemp/*

and this should be
mkdir /Users/frontrow/OStemp
rm /Users/frontrow/OStemp/*

I also choose to edit line 53 and swap the "mv" to a "cp" command, as otherwise all your downloaded files are deleted from the appleTV on reboot after update (this might be wanted - I like backups).

Auto-scripts want read-write

Do not forget that the auto scripts want a read-write mounted disk... This is the command you'd want to use if yours isn't set to mount RW by default: sudo mount -uw /

Today I tried to install a modified 2.2 disk image. It didn't work so far. Osupdate restarts the ATV and then the update process beginns. But as soon as the white slider moves a few pixels an error message pops up and says: unable to install update. Press menu to recover AppleTV.

First I used a very heavy ATV 2.2 update with all necessary files installed. Then I tried the it again with just ssh and nitotv. Didn't work either. So this obviously doesn't work ...