From AwkwardTV
Jump to: navigation, search

Would it be possible to add an UPNP Client to NitoTV so that I could watch movies from my NAS storage?


Better yet, isn't Nito interested in releasing nitoTV under a Free Software (GPL would be great, The MIT License would be nice too) license, so all of us that have some programming skill can help improving it? Mind you, this is a respectful request, not a demand. Massa 12:27, 12 June 2007 (CEST)

- I've followed all the instructions, but when trying to play a DVD folder, I get thrown to the Apple Logo, and after a few seconds back to the menu. This is with both the DVD framework loaded and not. I thought if the DVD framework wasn't present, it defaulted to mplayer?

File Order

Is there a way to order the files displayed? I'm using an nfs mount from my nas and there is no apparent order to the files when viewed via NitoTV. They aren't ordered alphabetically or by date and when I add new files, the can appear anywhere on the list.

How to change default position of subtitle?

For my taste subtitles comes too low. Now I have to adjust position in every movie. Is it possible to edit some settings file to change default position?

Install HOWTO ?????

I still did not figure out how to install the new (0.2.5bX) nitoTV. Can anyone enlighten me? [User:Massa|Massa]] 02:51, 26 August 2007 (CEST)

To install it, you will need to copy the NitoTV folder from into your AppleTV. You can copy it to the home folder of the 'frontrow' user if you wish, although its location doesn't really matter.

Next, you need to open an SSH connection to your AppleTV, like so:

ssh -1 frontrow@<your_appletv_address>

When prompted for a password, enter 'frontrow'.

Now go to the directory where you placed this folder on your AppleTV and type the following command:

sudo ./installme

When prompted for a password, enter 'frontrow' again

File Formats

I was wondering if really all mplayer formats are working? How about 720p or 1080i/p movies/series? Has anyone tried "Matroska" files (MKV)? This plugin might be the reason to finally buy an AppleTV!!! Keep up the great work! Smart1999 10:27, 5 September 2007 (CEST)

Error on latest version

While running from the AwkwardTV plugin installed with patchstick, my ATV whines about "The SetupHelper was not running with adequate privileges to perform the operation. Try re-running the Patchstick install process to repair this."

I ran from cmdline and all worked just fine.

Also, the fact that this automatically runs the safe updater is awesome. I'm gonna try integrating it on a patchstick and see what happens... Cheers! ProfessaFresh 14:38, 26 September 2007 (CEST)

NUV - Nupplevideo containers

MythTV transcodes mpg files into mpg files inside a Nupplevideo container. This is playable within Mplayer, but the directory listsings seem to ignore the extension - can I get NitoTV to 'recognise' the filetype? --Gonkyhead 18:37, 22 December 2007 (CET)

Take 2 Version Compatibility?

Installed the current version 0.3.1 on my AppleTV first and it never showed up, tho the application said the install was successful. Tried the link under "Take 2 Status" which links to version 0.2.2 and it DID show up after another successful install.

any suggestions, or is 0.2.2 the most current version for Take 2?

nitoHelper needs repair error in the log when trying to run Smart Installer

For anyone who is having an issue running the Smart Installer, the fixperm script apparently doesn't completely fix the permissions.

I was able to find some info on a google cached copy of a page on the atv4windows site that fixed the issue.

from a bash prompt:

cd /System/Library/CoreServices/

sudo chmod 755 nitoHelper

sudo chmod u+s nitoHelper

Once I did this I was able to get the Smart Installer to run.

--Ejsjrnc 04:00, 7 July 2008 (CEST)