Talk:Composite

From AwkwardTV
Jump to: navigation, search

4:3 aspect ratio in 2.1

I've had a 4:3 aspect ratio working in 2.0 (after some serious fiddling and trying out different timeouts before calling displayutil), but in 2.1, *nothing* seems to work anymore. Has anybody got it working? --Luggi 15:38, 15 July 2008 (CEST)

I've also tried just about everything I could find and am still stuck. Even when I tried to run a startup script, I got the aTV to flicker in and out of resolutions while staying pretty much stuck at the apple screen. Seems to me like it could work, but something inside is seriously stopping it.

Can someone explain why this isn't easy like configuring GNOME on Linux? I feel like there should just be something we can patch to make this work...

--Gneox 23:47, 29 July 2008 (CEST)

I've spent ridiculous amounts of time working on this lately. Something happens after loginwindow (I think) which is different than in earlier versions of the OS. Something is manually rewriting windowserver's plist during boot. You can change it manually, and it will temporarily show the new resolution on a reboot, but the display setup tool seems to automatically pick a standard resolution after boot. It may have done this before when displayutil was working. Just posting my observations thus far.

The real issue seems to be that there's been some sort of change to CoreGraphics. I've seen another application called newscreen, which a replacement for cscreen - which does something much like what I imagine displayutil does. (You can find source code it here - no binary is provided, though I have compiled it and it doesn't work on ATV: http://forums.macosxhints.com/showthread.php?t=59575) I THINK it's making Quartz Graphics calls that aren't valid in the version CoreGraphics currently being used in the post 2.1 versions of the OS. So it runs but doesn't do anything. So far that's all I've been able to come up with. I've tried relaunching the windowserver multiple ways in combination with crashing finder, but I can't seem to get the display to reload the windowserver preferences file.

I've also tried doing the trick with the boot plist file, and that won't set the resolution either. If anyone else has any ideas, please share.

--Spectre2k5 05:25, 11 January, 2009 (EST)

For those fearful of upgrading to 2.3, displayutil did the trick of converting to 4:3 on this version (until reboot, that is). I had to unload/reload TVComposite.kext to get my color back again after running displayutil. If I solve the reboot issue I'll post whatever info I gather.

So far, what I have is the following script that works but not with 100% reliability (run as sudo).

#! /bin/sh
kill `ps awx | grep [F]inder | awk '{print $1}'`
sleep 5
./displayutil -b 32 -r800x600
sleep 2
kextunload -q /System/Library/Extensions/TVComposite.kext
kextload -q /System/Library/Extensions/TVComposite.kext

The long sleep is necessary, furthermore it doesn't work when run from the main menu, only when one of the apps such as "Music" or "nitoTV" is already running. This is a timing issue, I think. Also, 640x480 didn't work well (too much black at the top of the screen) which is why I used 800x600. AFAIK the nVidia TV-Out can handle input resolutions up to 1024x768 and automatically downscales them to TV resolution, or at least it does on Linux.

A further note: if nitoTV is installed, its "screen release" options must be off since they break any changes that we make to the screen resolution.

--Foghorn 01:12, 13 January 2009 (CET)

In ATV 3.0.2, i succeeded in changing to any resolution/aspect ratio : I installed SwitchResX (with of course mouse support and System Preferences installed), and copied the Displays pref pane and /System/Libraries/Displays/ from a 10.4 install to the Apple TV. I launch it from the Nito->Applications menu. From there I can choose every standard resolution, or create my own one with SwitchResX. --WaterCooled 10:12, 3 March 2010 (CET)

Do we really need a StartupItem / rc.local for displayutil?

Once I have adjusted my resolution using displayutil, I did not need a StartupItem after reboot, the resolution remains. That's the command I used (the other command did not work for me):

kill `ps awx | grep [F]inder | awk '{print $1}'`; sleep 1; displayutil -r800x600 -b32

--Mcka 13:15, 1 December 2007 (CET)

What is the correct resolution for 4:3 SD TV, connected by composite?

I thought it would be PAL resolution (768x576), but this did not work, as well as 720x576 did not work. The only working settings are 800x600 and 640x480. Which one should I choose? 640x480 zooms in, 800x600 zooms out. Before i used 576i from ATV menu, but this was the wrong aspect ratio. Any ideas? --Mcka 13:19, 1 December 2007 (CET)

More help needed

When using this command: sudo /sbin/kextload -v /System/Library/Extensions/TVComposite.kext

no errors are reported but still no colors?

Any suggestions to what might be the problem?


Info:

I have tried using the application menu plugin method and the startupitem method but no luck I have tried to revert to factory setting v1.0 and starting the process all over too.

My tv is a pal tv.


Please add some trouble shooting tips to the page. --Rsn7777 01:29, 17 February 2008 (CET)


Solved: What I think is unclear from the manual page is that the TVComposite.kext should also be in the /users/frontrow folder

When following the manual page you move the TVComposite.kext as you should to the extensions folder. But there is no mention of the need to still have it also in the /users/frontrow folder.

--Rsn7777 21:19, 17 February 2008 (CET)

Hi Rsn7777 - Ive got the same problem. could you provide any hints. I got this worked by playing around once (2.0.2) with the wiki discription and typing in some of the desciption commands manually. then I decided to delete all of the autoplay stuff that did not worked so far with the result that the command line enabling (which I do not remember exaclty, but I think it was "sudo /sbin/kextload -v /System/Library/Extensions/TVComposite.kext" did not work any more again. recreated the files but now I am not able to enable color manually. Any advice what to look for?

rds. Knarfbox

displayutil does not work with ATV 2.0 anymore

If I try to use displayutil as described below, it ATV jumps to the menu to select a resolution, but the desired resultion is not there. Any ideas how to work around that? --Mcka 01:36, 18 February 2008 (CET)

Using "sudo" seems o help. --Mcka 01:38, 18 February 2008 (CET)

But it's away after reboot, so a StartupItem is needed. --Mcka 01:40, 18 February 2008 (CET)

That's the StartupItem Skript I use to make it work with ATV 2 again:

#!/bin/sh
. /etc/rc.common

# change resolution 
kill `ps awx | grep [F]inder | awk '{print $1}'`
sleep 1
/System/Library/StartupItems/ATV_Composite/displayutil -r800x600 -b32

# load Composite kext
kextload /System/Library/StartupItems/ATV_Composite/TVComposite.kext

AS you can see, I've put TVComposite.kext and displayutil in the StartupItem directory, which makes it easier to restore for future updates.

But there are still strange things, changing resoltion does not work allways, and I don't see the startup intro anymore, and no Covers in the background of the "home screen"... If you know how to make this work again, let me know! --Mcka 04:42, 18 February 2008 (CET)

I'm a newbie in this and can't find enough about that in the web, so ... how do I create a StartupItem Skript? --Zwen 14:29, 05 March 2008

Working: Colour and 768x576 on PAL TV

I've managed to get 768x576 resolution working in colour on my PAL TV (a 68cm Sony Trinitron, FWIW). Very similar to what Mcka shows above. Two differences which may be relevant - do let me know. First, I've set the StartupParameters.plist to load first (got that idea from the Composite wiki page):

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist SYSTEM "file://localhost/System/Library/DTDs/PropertyList.dtd">
<plist version="0.9">
    <dict>
        <key>Description</key>
        <string>ATV_Composite</string>
        <key>OrderPreference</key>
        <string>First</string>
        <key>Provides</key>
        <array>
                <string>ATV_Composite</string>
        </array>
    </dict>
</plist>

Second, I invoked turbo_kext_enabler from within the startup script:

#!/bin/sh
. /etc/rc.common

# change resolution 
kill `ps awx | grep [F]inder | awk '{print $1}'`
sleep 1
/System/Library/StartupItems/ATV_Composite/displayutil -r768x576 -b32

# load Composite kext
/Users/frontrow/turbo_kext_enabler.bin
kextload /System/Library/StartupItems/ATV_Composite/TVComposite.kext

Although I now see the 768x576i resolution selected in the Settings/Video/Resolutions menu in ATV, it's at 60Hz, and I believe 50Hz is what I want. Certainly when I select the 576i @50Hz widescreen res (one of the default ones) the picture is clearer (although distorted). There's also a lot of image lost in the overscan area, and I get a much better result using 1024x768 resolution (just change the res in the startup script). That still shows as 60Hz though.

So, any ideas on how to force the refresh rate to 50Hz? Will it make a difference? --TicToc 02:17, 9 March 2008 (CET)

Composite color in 2.02 with ATV4windows 2.4

Ok, figured it out... now it boots in composite color...

I replaced the NTSC files within the pal folder for TVComposite.kext, like awkward said to... http://wiki.awkwardtv.org/wiki/Composite

sudo mount -uw /
sudo chmod -R 755 TVComposite.kext
sudo chown -R root:wheel TVComposite.kext

but I didn't move the file, i left it in /Users/frontrow/ it seemed when i moved the file to /System/Library/Extensions/ it would no longer load, and I don't understand the voodoo behind it.

then i ran the compile app, which is also voodoo, but it makes things color for this boot.

sudo ./compile


Then to get it to boot I modified the ole autoexec.bat equivalent by first viewing it...

nano /etc/rc.local

since you can't edit the file, I copied the contents...

# rc.local
# enable USB
/sbin/turbo_kext_enabler.bin
/sbin/kextload -v /System/Library/Extensions/IOUSBMassStorageClass.kext
/sbin/kextload -v /System/Library/Extensions/smbfs.kext
/sbin/kextload -v /System/Library/Extensions/udf.kext
/sbin/kextload -v /System/Library/Extensions/msdosfs.kext
/sbin/kextload -v /System/Library/Extensions/ntfs.kext
# enable cron
/usr/sbin/cron

then closed the file control-x

i made a new file in /users/frontrow

nano rc.local

pasted the above into the blank file,

and added
/sbin/kextload -v /Users/frontrow/TVComposite.kext

to the last line. saved it, then moved it to overwrite the old file...

sudo mv rc.local /etc

then changed ownership...

sudo chown -R root:wheel /etc/rc.local

sudo reboot

now it boots in color.

awkward says this wont work, however every other hack on awkward did not work to boot it to color, this did.

Took too long to figure it out as I am just a tinkerer. - icedmango

2.4 update - any success?

After updating to apple tv 2.4 software & re-installing the TVComposite,kext etc, the software hack doesn't appear to do the trick anymore - the image remains black & white.

Is there anyone out there who managed to make it work under 2.4?

- Martin

I was having the same issue until I came across http://forum.awkwardtv.org/viewtopic.php?f=3&t=2397&start=0 <---that thread. For whatever reason, if the ethernet cable is plugged in, and you boot it, you get B&W, if you leave the ethernet cable unplugged and boot up, THEN plug it back in...all is well... ~RavenII

I was able to get this to work in 2.4 and 3.01 using the long script method with the modifications that I just posted. I could NOT get the nitoTV automatic install for TVComposite to work on either 2.4 or 3.01. I'm using wireless, so have not tried with the ethernet cable plugged in.