XBMC

From AwkwardTV
Revision as of 00:35, 5 February 2008 by Maraklov (talk | contribs) (XBMC binary experimentation. no success.)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

XBMC for Mac OS X 0.1 has been released.

  • For Leopard and Intel only.

Get it here: http://www.osxbmc.com/2008/02/04/release-01-hundredths-are-for-wimps/


Attempts to get it running as-is on safe updated 1.1 ATV have come up short. Of course, this is to be expected,

Here's the error in CrashReporter.log:

Library not loaded: /opt/local/lib/libiconv.2.dylib
 Referenced from: /mnt/Scratch/Users/frontrow/Applications/XBMC.app/Contents/Mac OS/XBMC
  Reason: Incompatible library version: XBMC requires version 7.0.0 or later, but libiconv.2.dylib provides version 5.0.0

Obviously, as it isn't a Tiger compatible release, it's doubtful we'll get it working in its current binary release but there's always the possibility of a Leopard-based Take2 update to the AppleTV, or a Tiger-compatible release of XBMC.

I expect some cleanup to this article as this might get more interesting as XBMC on Mac OS X development continues. Just adding my trials and tribulations. Maraklov 09:35, 5 February 2008 (CET)