Difference between revisions of "XBMC"

From AwkwardTV
Jump to: navigation, search
m
Line 3: Line 3:
  
 
Instalation Instructions
 
Instalation Instructions
XBMC for Mac (beta1) is now released, here's the short and sweet to install;
+
XBMC for Mac (beta 1) is now released, here's the short and sweet to install;
  
 
Requirements: AppleTV at r2.1, ssh and NitoTV installed. (see http://wiki.awkwardtv.org/wiki/Main_Page)
 
Requirements: AppleTV at r2.1, ssh and NitoTV installed. (see http://wiki.awkwardtv.org/wiki/Main_Page)
  
The AppleTV need read/write enabled for OSBoot, (search the awkwardtv wiki for readwrite [[Mount_ReadWrite]]).
+
The AppleTV needs read/write enabled for OSBoot, (see [[Mount_ReadWrite]]).
  
 
under a ssh login into the AppleTV
 
under a ssh login into the AppleTV

Revision as of 05:06, 6 October 2008

XBMC for AppleTV Take2 http://xbmc.org/forum/showthread.php?t=37345

Instalation Instructions XBMC for Mac (beta 1) is now released, here's the short and sweet to install;

Requirements: AppleTV at r2.1, ssh and NitoTV installed. (see http://wiki.awkwardtv.org/wiki/Main_Page)

The AppleTV needs read/write enabled for OSBoot, (see Mount_ReadWrite).

under a ssh login into the AppleTV

installer -pkg XBMC.mpkg -target /

Ignore the message about installation failing, a perl post-install script has failed to run because perl is missing

This installs ;

/Applications/XBMC.app

make a sym link from /Applications to ~/Applications so NitoTV app launcher can see it

ln -s /Applications/XBMC.app /Users/frontrow/Applications/XBMC.app

Launch it under NitoTV

setting-> appearance-> resolution and pick the one with (FullScreen)




XBMC for Mac OS X Beta 1 has been released.

  • For Intel only.

Get it here: http://xbmc.org/download

Attempts to get it running as-is on safe updated 1.1 ATV have come up short. Of course, this is to be expected,

Here's the error in CrashReporter.log:

Library not loaded: /opt/local/lib/libiconv.2.dylib
 Referenced from: /mnt/Scratch/Users/frontrow/Applications/XBMC.app/Contents/Mac OS/XBMC
  Reason: Incompatible library version: XBMC requires version 7.0.0 or later, but libiconv.2.dylib provides version 5.0.0

I expect some cleanup to this article as this might get more interesting as XBMC on Mac OS X development continues. Just adding my trials and tribulations. Maraklov 09:35, 5 February 2008 (CET)