Difference between revisions of "Connecting drive to PowerPC Mac"

From AwkwardTV
Jump to: navigation, search
m
(Report another success using a G5)
Line 13: Line 13:
  
 
'''Worked on my PowerBook G4 without any problem. - jsh
 
'''Worked on my PowerBook G4 without any problem. - jsh
 +
 +
'''Just wanted to report another success w/ using a Dual G5 - kazoolist'''
  
 
After hooking up the drive to a PowerPC based mac, the AppleTV can no longer boot (just get a flashing appleTV logo with a question mark over it). IF anyone has any ideas, or a solution to at least restore the drive, please post here. I think what happens is the disk is set to no longer be bootable. Does anyone know a command line command to set a partition to bootable?
 
After hooking up the drive to a PowerPC based mac, the AppleTV can no longer boot (just get a flashing appleTV logo with a question mark over it). IF anyone has any ideas, or a solution to at least restore the drive, please post here. I think what happens is the disk is set to no longer be bootable. Does anyone know a command line command to set a partition to bootable?

Revision as of 17:57, 12 June 2007

No Longer Booting

**MINE WAS FINE: Just so people with PPC Mac's know -- I have connected the Apple TV drive to my Power PC (Dual G5) and re-installed that into my Apple TV. Boots and plays files fine, ssh working as well (used openssh since I don't have an intel mac) Other should post some successes here as well since this is one occurrence and seems to be a anomaly.*** - Zerostar

Mine has been connected to both a PowerBook G4 and a Dual G5. No issues. -mrfett

Worked for me just fine (dual g5) -pin

Worked for me iMac g5 - arn636

Worked for me on my Mac mini G4 -bjdraw

Worked on my PowerBook G4 without any problem. - jsh

Just wanted to report another success w/ using a Dual G5 - kazoolist

After hooking up the drive to a PowerPC based mac, the AppleTV can no longer boot (just get a flashing appleTV logo with a question mark over it). IF anyone has any ideas, or a solution to at least restore the drive, please post here. I think what happens is the disk is set to no longer be bootable. Does anyone know a command line command to set a partition to bootable?

% diskutil info disk2
  Device Node:        /dev/disk2
  Device Identifier:  disk2
  Mount Point:        
  Volume Name:        

  Partition Type:     GUID_partition_scheme
  Bootable:           Not bootable
  Media Type:         Generic
  Protocol:           USB
  SMART Status:       Not Supported

  Total Size:         37.3 GB
  Free Space:         0.0 B

  Read Only:          No
  Ejectable:          Yes
  OS 9 Drivers:       No
  Low Level Format:   Not Supported

% diskutil info disk2s1
  Device Node:        /dev/disk2s1
  Device Identifier:  disk2s1
  Mount Point:        
  Volume Name:        

  Partition Type:     EFI
  Bootable:           Not bootable
  Media Type:         Generic
  Protocol:           USB
  SMART Status:       Not Supported

  Total Size:         34.0 MB
  Free Space:         0.0 B

  Read Only:          No
  Ejectable:          Yes

% diskutil info disk2s2
  Device Node:        /dev/disk2s2
  Device Identifier:  disk2s2
  Mount Point:        
  Volume Name:        

  Partition Type:     5265636F-7665-11AA-AA11-00306543ECAC
  Bootable:           Not bootable
  Media Type:         Generic
  Protocol:           USB
  SMART Status:       Not Supported

  Total Size:         400.0 MB
  Free Space:         0.0 B

  Read Only:          No
  Ejectable:          Yes

% diskutil info disk2s3
  Device Node:        /dev/disk2s3
  Device Identifier:  disk2s3
  Mount Point:        /Volumes/OSBoot
  Volume Name:        OSBoot

  File System:        Journaled HFS+
                       Journal size 8192 k at offset 0x65b5000
  Owners:             Enabled
  Partition Type:     Apple_HFS
  Bootable:           Not bootable
  Media Type:         Generic
  Protocol:           USB
  SMART Status:       Not Supported
  UUID:               5F7DBFAD-B44F-3B25-839B-954D488BA529

  Total Size:         900.0 MB
  Free Space:         452.7 MB

  Read Only:          No
  Ejectable:          Yes

Fix

I did not have this problem and I connected the drive to my PowerPC, but from the diskutility dump that you pasted it does not look like you have a Media partition created. You can't create this through DiskUtility though as it will break. You can use iPartition, or you can go add it with gpt:

# gpt add -s 309849759 -i 4 /dev/disk2

(you will want to change 309849759 to the # of blocks available on the drive. That # is the amount of free blocks I had on the 160 GB drive I upgraded to)