Backr00m

From AwkwardTV
Revision as of 18:26, 31 May 2019 by Nito (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

backR00m Jailbreak for AppleTV 4 & 4k for tvOS 10.2.2 - > 11.1
Current Version: 1.2.3

Release date: May 31st 2019
Current as of: May 31st 2019


backr00m is a jailbreak for tvOS 10.2.2 -> 11.1 for AppleTV 4+. It is based on meridian and electra jailbreaks by PsychoTea and ElectraTeam respectively. It utilizes jailbreakd to avoid buggy KPPBypass bugs.

This application is Copyright © 2007-2018 nito llc. All Rights Reserved.

Changelog

1.2:

  • reboot works cleanly,
  • update bootstrap to include latest nitoTV / TweakInject / substitute etc.
  • Should no longer need KPPless to set a nonce and boot in recovery
  • added ability to set a nonce for 11.1 jailbreak. (double tap the play/pause button when (re)jailbreaking your device to set the nonce in 11.1.)

1.1:

  • Some bootstrap and package bug fixes

1.0:

  • Initial release

Install Instructions for AppleTV 4

Step 1: Download backr00m

Step 2: Plug your 4th generation AppleTV into your computer via a USB-C cable

Step 3: Make sure you have a developer account with apple, you can get one for free (your on your own to figure that out!)

Step 4: Download Cydia Impactor

Step 5: Drag the backr00m.ipa into Cydia Impactor

Step 6: Click start

You will almost definitely get some error related to plist files, i dont remember the exact error, this error is fine and expected behavior (it happened every time for me) check your AppleTV to see if its installed

Step 7: Run backr00m and hit the 'Jailbreak' button it should work on the first try! Hit the respring button when prompted to. Once two respring's have occurred nitoTV should launch automatically!

Future Restore Instructions

Preparation

You will need the target OS blobs saved for your 4th generation AppleTV (12.1.1 is latest version that can be jailbroken at this time). If you do not have those, you cannot restore to said version. 11.2.x can no longer be installed because there aren't any SEP versions that are still signing that are compatible. These directions are mac specific but with minor changes should work on any comp. 11.3->12.1.1 should all still be possible to restore to, anything before that will not work with any signing SEP versions.

Step 1: Download futurerestore for your respective computer, here is the build i use that works on my mac futurerestore_macos

Step 2: Open your terminal app (for mac os only, linux and windows you are on your own here)

Step 3: create a directory that has your SHSH blob saved, or 'cd' to the directory that has it

Step 4: open your blob file and find the 'generator' inside of it, make a note of this value.

Step 5: Download the target ipsw for the version you have blobs saved for: ipsw download links

backr00m install

Step 1: Download backr00m

Step 2: Plug your 4th generation AppleTV into your computer via a USB-C cable

Step 3: Make sure you have a developer account with apple, you can get one for free (your on your own to figure that out!)

Step 4: Download Cydia Impactor

Step 5: Drag the backr00m.ipa into Cydia Impactor

Step 6: Click start

You will almost definitely get some error related to plist files, i dont remember the exact error, this error is fine and expected behavior (it happened every time for me) check your AppleTV to see if its installed

Step 7: Run backr00m

Step 8: Click the 'Jailbreak' button it should work on the first try! Hit the respring button when prompted to. Upon respringing SSH into your AppleTV

Step 9: ssh into your device (ie 'ssh root@apple-tv.local') default password is alpine

Step 10: run this command (substitute your generator in place that you got from the final "preparation" steps)

 nvram com.apple.System.boot-nonce=YOUR_NONCE_HERE

Step 11: run this command

 nvram auto-boot=false

Step 12: run this command

 reboot

Step 13: from the directory in the terminal with your future restore files run the following command (with your file names substituted in place)

 ./futurerestore -t YOUR_SHSH_BLOB.shsh -w THE_IPSW_YOU_DOWNLOADED.ipsw  --no-baseband --latest-sep

Step 14: Profit!

Known Issues

1. Youtube video playback doesn't work (this isn't a backr00m issue, youtube doesn't work on 10.2.2 AT ALL)